はじめに
b→dashへデータを連携するにあたっての全体像や、どのような連携方法があるかを知りたい場合は、まずは以下の記事をご覧ください
ローカルファイルをb→dashにアップロードする手順
PCのローカルに保存されているファイルをb→dashにアップロードする手順をご説明します。
ローカルデータをアップロードするためにはユーザーの所属する権限グループの「
データファイル詳細画面の参照/加工/統合」権限が「
編集可」である必要があります。
権限設定の詳細については「
権限設定をしたい」をご参照ください。
「データパレット」をクリックします

「データを確認」をクリックします

右上にある「矢印マーク」をクリックします

「アップロードしたいローカルファイル」を選択します

一度にアップロードできるファイルの上限は?
アップロードできる1ファイルあたりのファイルサイズは1GB、同時にアップロードできるファイル数は10ファイルが上限となります。
ローカルファイルにパスワードをつけてもいいの??
ローカルファイルにアップロードする場合は、ファイルにパスワードが設定されていると、取り込むことが出来ませんので注意しましょう。
ファイルが左上に追加されます

ローカルファイルのアップロードにおいて取り込めるファイル形式

※ファイルの内容がcsv/tsv形式で記述されている「テキストファイル(.txt)」も取り込むことができます
表示されるトースト(通知バナー)の上限数について
データファイルのアップロード時に表示される「トースト」(通知バナー)は、同時にアップロードするデータファイルの件数によって、ダウンロード時に表示されるトーストの数が異なります。
データファイルを同時にアップロードする件数が「3件以下」の場合、アップロードするデータの件数分、トーストが表示されます。一方で「4件以上」の場合は、アップロードするデータの件数に関係なく、トーストが「1件のみ」表示されます。
【参考:3件の場合】

【参考:4件の場合】

ローカルファイルをアップロードできない場合はどうすればいい??
考えられる原因 |
改善策 |
ファイル形式が誤っている |
b→dashにアップロード可能なファイル形式はCSV、もしくはTSVになります。
テキスト形式やエクセル形式のファイルはアップロードいただけませんのでご注意ください。
【アップロード不可のファイル例】
・テキストファイル(.txtなど)
・エクセルファイル(.xls .xlsxなど)
・圧縮ファイル(.zipなど)
・BOM付ファイル(BOMとは、Unicodeで符号化したテキストの先頭に付与される数バイトのデータのことです。)
■参考サイト |
アップロード頂けるファイルの容量を超過している |
ローカルアップロードでアップロード頂けるファイルの最大容量は、1GBとなっております。
アップロード頂いたファイルの容量が、1GBを超えていないかご確認をお願いいたします。
もしくは、1GBを超えている場合は、分割頂くかSFTP連携でのファイル連携をご検討ください。 |
文字コードが取り込めない形式となっている |
b→dashにアップロードいただくことのできる文字コードはUTF-8,Shift-JISとなっております。
異なる文字コードでのアップロードを行った場合は、取り込み時にエラーが発生してしまいますので、文字コードをご変更の上アップロードいただきますようお願いいたします。
文字コードは「メモ帳(テキストエディタ)」にてご確認をいただくことが可能ですので、以下のサイトをご参照いただきご確認の上アップロードをお願いいたします。
■参考サイト |
ファイルのヘッダー行のカラム数とレコード行のカラム数が異なる |
アップロードいただくファイルのヘッダー行とレコード行のカラム数が異なっている場合、b→dashにてデータを整形することができないため取り込みエラーが発生してしまいます。
よくあるケースとして、カンマが末尾についてしまいレコード行のカラム数がずれてしまうケースが御座いますので、ヘッダー行とレコード行のカラム数が一致しているかご確認をお願いいたします。 |
取込設定を行われているデータファイルのデータ型とアップロードいただいたファイルのデータが一致していない |
取込設定時に各項目でデータ型の設定を行いますが、アップロードしたファイルの一部項目のデータ型が設定と異なる場合にファイルがアップロードできない場合が御座います。
例)データ型「日時」で設定している項目に対して、「テスト」のような文字が入っている
アップロード頂いたファイルの値とデータファイルのデータ型のご確認をお願いいたします。 |
取込設定を行われているデータファイルの項目数とアップロードいただいたファイルの項目数が一致していない |
アップロードしたファイルの項目数と、連携先のデータファイルの項目数が一致していない場合、別ファイルとして扱われてしまうため、ファイルの取込条件が合致していてもプラスボタンにファイルが連携されてしまいます。
アップロードしたファイルの項目数がデータファイルの項目数と一致しているかご確認をお願いいたします。 |
別のデータファイルにデータが取り込まれてしまった |
ローカルエリア内にあるデータファイルに取込み条件が一致している場合、アップロード頂いたファイルが自動でデータファイルへ取り込まれます。
アップロードいただいたファイルが、他のデータファイルの取込み条件と一致していないかご確認をお願いいたします。
また、複数条件と一致していた場合は、取込設定を行ったタイミングが、新しい方のデータファイルに取り込まれます。
【確認方法】
1. データパレット>データを確認するをクリック
2. 「取込設定」をクリック
3. アップロード頂いたファイルに合致する取込み条件のデータファイルがないか確認
【対策】
例)Salesから始まるファイルとSalesdetailから始まるファイルがある場合は下記のようにご設定をお願いいたします。
・Salesの取込対象ファイル条件
ファイル名が 次で始まる Sales
ファイル名が 次を含まない Salesdetail
・Salesdetailの取込対象ファイル条件
ファイル名が 次で始まる Salesdetail |
ファイルを表示することができないなど、読み取れない状態である |
b→dashでは、破損しているファイルを取り込むことが出来ません。
そのため、ファイルが破損してしまっている場合はアップロードの際にエラーが発生致しますので、
ローカルのフォルダにて一度ファイルを表示して内容を確認できる状態であるかご確認いただきますようお願いいたします。 |
貴社のFW(ファイヤーウォール)の設定により、ファイルのアップロードが制御されている |
貴社が運用しているFW(ファイヤーウォール)に対して、以下のFQDNとポート番号に対するファイルアップロードを許可する設定を実施ください。
FQDN:bdash4-preparation-prd.s3-ap-northeast-1.amazonaws.com
ポート:443(https) |